Search found 1366 matches

by Basicmicro Support
Tue May 26, 2020 7:59 am
Forum: General Discussion
Topic: Trouble reading packet serial data with Arduino Mega
Replies: 2
Views: 41

Re: Trouble reading packet serial data with Arduino Mega

First change your Roboclaw baudrate. Arduino cant do 230400. It rounds up to 250000 IIRC. 115200 usually is ok but that rounds down to 111111 on the arduino. Next if you have an oscope check the S2 pin on the Roboclaw is outputing anything when you send a readversion command. If the pin is always lo...
by Basicmicro Support
Fri May 22, 2020 8:34 am
Forum: Velocity and Position Control
Topic: RoboClaw Solo 60A conneting to a AndyMark PG188 motor
Replies: 3
Views: 74

Re: RoboClaw Solo 60A conneting to a AndyMark PG188 motor

Some encoders need pullup resistors from the A and B signals to 5v to work correctly. The Andymark documentation doesnt mention it as far as I could find but I've seen that issue before. If you have a scope you can see if the encoder signals are correct(square wavees 0 to 5v amplitudes, if not I'd t...
by Basicmicro Support
Thu May 21, 2020 8:49 am
Forum: Velocity and Position Control
Topic: RoboClaw Solo 60A conneting to a AndyMark PG188 motor
Replies: 3
Views: 74

Re: RoboClaw Solo 60A conneting to a AndyMark PG188 motor

1. Make sure you are suing Basicmicro Motion Studio. Ion Studio is very old and only available for legacy purposes. 2. You can see the pinouts of their encoder on this page: https://www.andymark.com/products/hall-effect-two-channel-encoder Based on the pictures: Red = 5v Black = GND Yellow = Ch A Gr...
by Basicmicro Support
Wed May 13, 2020 8:04 am
Forum: General Discussion
Topic: Basicmicro Motion Studio freezes when moving motor 1 forward
Replies: 1
Views: 900

Re: Basicmicro Motion Studio freezes when moving motor 1 forward

First re-update the firmware, then uynder device menu click restore defaults. Retest. If the problem persists swap motor 1 with motor 2. Another possibility is the motor caused a USB glitch. USB on Windows is sensitive to noise. Some motors are worse than others. You may need to use a USB isolation ...
by Basicmicro Support
Tue May 05, 2020 8:03 am
Forum: General Discussion
Topic: Roboclaw Solo 30A, Motor Controller
Replies: 8
Views: 3002

Re: Roboclaw Solo 30A, Motor Controller

I recommend always checking with us if you get stock on something for more than a couple hours. Phone for fastest response of course but don't bang you head against a wall for days. 99 times out of 100 we have already seen the problem you are having and can give you a quick fix.
by Basicmicro Support
Tue May 05, 2020 8:02 am
Forum: General Discussion
Topic: Using Packet Serial in .NET - RoboClaw 2x60a
Replies: 3
Views: 1516

Re: Using Packet Serial in .NET - RoboClaw 2x60a

Ah, yes. That as well. I didnt look up the command number to see which command you were using. The mixed compatibility commands need both to start. Once started either can be used to change the movement.
by Basicmicro Support
Tue May 05, 2020 8:00 am
Forum: General Discussion
Topic: Using 3 roboclaw, packet serial, USB
Replies: 6
Views: 2869

Re: Using 3 roboclaw, packet serial, USB

What version of python are you using? to_bytes is in python3 roboclaw libary, not python2.7. You need to use the appropriate python Roboclaw library for your specific python version, roboclaw.py for python2.7 and roboclaw_3.py for python3+.
by Basicmicro Support
Mon May 04, 2020 8:15 am
Forum: General Discussion
Topic: Using Packet Serial in .NET - RoboClaw 2x60a
Replies: 3
Views: 1516

Re: Using Packet Serial in .NET - RoboClaw 2x60a

1. you should read back a byte after sending the command packet. If you get a return value then the packet was valid. If you dont get a byte within 10ms the crc was wrong. Set a 10ms timeout for the read command. then if you get a byte continue and if you get a timeout instead you can handle the err...
by Basicmicro Support
Mon May 04, 2020 8:07 am
Forum: General Discussion
Topic: Roboclaw Solo 30A, Motor Controller
Replies: 8
Views: 3002

Re: Roboclaw Solo 30A, Motor Controller

If you tuned the motors using Motion Studio and wrote the settings to the Roboclaw, remove the SetVelocityPID commands from your examples. Those are overriding the settings in the controller which is probably most of your problem.
by Basicmicro Support
Mon May 04, 2020 8:05 am
Forum: Velocity and Position Control
Topic: Default Accel and Velocity Control
Replies: 1
Views: 2116

Re: Default Accel and Velocity Control

Default Accel only applies to commands that do NOT have an accel argument. If the command has an accel argument it overrides.