Search found 8 matches

by robg
Tue Mar 05, 2019 2:14 pm
Forum: Velocity and Position Control
Topic: Absolute and quadrature encoding
Replies: 2
Views: 441

Re: Absolute and quadrature encoding

Okay, Found by chance this: https://forums.basicmicro.com/viewtopic.php?f=3&t=777&p=2677&hilit=absolute+and+quadruple+enc1#p2677 So changing the software from IonStudio to BasicMotion fixed the problem, which is ridiculous. Why allow updates of IONStudio which doesn't work and is no longer supported...
by robg
Tue Mar 05, 2019 12:46 pm
Forum: Velocity and Position Control
Topic: Absolute and quadrature encoding
Replies: 2
Views: 441

Absolute and quadrature encoding

Hi, Scrathing my head on this one, have a two motor setup with one using absolute and the other using quatrature encoding. Both motors work and provide feedback only via Encoder M1 and only relevant encoding selected on that particular motor on M1 ie Quad or abs. will it provide feedback. It seems b...
by robg
Fri Mar 02, 2018 6:04 pm
Forum: General Discussion
Topic: boards without connectors or with B2B connectors
Replies: 1
Views: 1430

boards without connectors or with B2B connectors

Hi,

Is it possible to purchase roboclaw 2 x 7A in small volume ie <10 without connectors installed?
Ideally like to plug the roboclaw onto another board, hence don't fancy the idea of desoldering!


Thanks,

Rob.
by robg
Fri Feb 16, 2018 11:39 am
Forum: Velocity and Position Control
Topic: Encoder question.
Replies: 4
Views: 2524

Re: Encoder question.

I guessed as much but thanks anyway.

Having worm drives not so much of an issue in my application.
by robg
Wed Feb 14, 2018 7:46 pm
Forum: Velocity and Position Control
Topic: Encoder question.
Replies: 4
Views: 2524

Re: Encoder question.

Thanks IMC support! Just came across this forum note ,10K pullups installed on the encoder outputs and works perfectly. On a full swing of the worm drive motor has a total range of 6447, it's pretty accurate +/- 2 Is there a method to store the position value if power is unexpectedly lost on robocla...
by robg
Wed Aug 09, 2017 2:32 pm
Forum: General Discussion
Topic: Serial Communications problem using Linux Kernel 4.10 and 4.12
Replies: 27
Views: 13568

Re: Losing communication with Roboclaw,TTL serial and Raspberry PI

Managed to resolve, and don't know why. So I'm posting this if others come across the same issue. But what I did do was: 1. Clean install of Jessie lite 2. Install pyserial 3. installed python roboclaw software (version I had was the latest) 4. modified the config.txt and enable_uart=1 (possibly dou...
by robg
Wed Aug 09, 2017 1:20 pm
Forum: General Discussion
Topic: Serial Communications problem using Linux Kernel 4.10 and 4.12
Replies: 27
Views: 13568

Re: Losing communication with Roboclaw,TTL serial and Raspberry PI

Hi, Greatly appreciated the reply. Downloaded from Pololu... Running Jessie Lite, RP3. Whilst I was updating Jessie, I thought had the problem licked. It was working perfectly, in fact I took out all delays and was reporting back continuous with sub second responses. After the updated had completed ...
by robg
Tue Aug 08, 2017 2:31 pm
Forum: General Discussion
Topic: Serial Communications problem using Linux Kernel 4.10 and 4.12
Replies: 27
Views: 13568

Serial Communications problem using Linux Kernel 4.10 and 4.12

Hi, Communciating with a Roboclaw via a serial TTL connection on a Raspberry PI using packet serial on default address. Robolcaw has firmware version 4.1.23 and communicating usign Python. Using the example roboclaw_readversion.py, loose communications after a few cycles of the app. Seems random, al...