Search found 9 matches

by laptophead
Fri Aug 10, 2018 6:58 pm
Forum: Velocity and Position Control
Topic: I would like to Sync 2 motors from Arduino commands
Replies: 7
Views: 2044

Re: I would like to Sync 2 motors from Arduino commands

I went into tuning, and improved it a bit, added more P and more I. Works a lot better, I guess it needs power to keep up the task.

It still not moving like is a one assembly but, good enough for now. Finally there are no 2 soldiers that walk in perfect cadence.

Great product , the roboclaw.
by laptophead
Fri Aug 10, 2018 4:51 pm
Forum: Velocity and Position Control
Topic: The latest update does not work 4.1.26
Replies: 2
Views: 1033

Re: The latest update does not work 4.1.26

Thanks

I chose to revert to .24 version, good enough for me.
by laptophead
Thu Aug 09, 2018 2:27 pm
Forum: Velocity and Position Control
Topic: The latest update does not work 4.1.26
Replies: 2
Views: 1033

The latest update does not work 4.1.26

I had to update from 4.1.24 to 4.1.26 on my roboclaws and it all seemed fine. Than I re-entered all the settings but the controller wont move. I got the M1OC and M2OC ligts red, but there is no current going to the motors. The sliders wont move any thing. I got the M1 Max current set at 4A, same for...
by laptophead
Thu Aug 09, 2018 12:27 pm
Forum: Velocity and Position Control
Topic: I would like to Sync 2 motors from Arduino commands
Replies: 7
Views: 2044

Re: I would like to Sync 2 motors from Arduino commands

thanks a lot for the clarifications. The syntax worked, here it is for other users: I replaced: roboclaw130.SpeedAccelDeccelPositionM1(adr130, 6000, 30000, 0, HorizGrip, 1); //Vertical Rot roboclaw130.SpeedAccelDeccelPositionM2(adr130, 6000, 30000, 0, HorizGrip, 1); //Hor Rotation of grip with one l...
by laptophead
Thu Jul 19, 2018 12:28 pm
Forum: Velocity and Position Control
Topic: I would like to Sync 2 motors from Arduino commands
Replies: 7
Views: 2044

Re: I would like to Sync 2 motors from Arduino commands

Thanks for the timely reply. I tried: roboclaw130.SpeedAccelDeccelPositionMixed(adr130, 6000, 30000, 0, 70000, 1); going to roboclaw130.SpeedAccelDeccelPositionMixed (adr130, 6000, 30000, 0, 90000, 1); and it does not compile. I got: class RoboClaw' has no member named 'SpeedAccelDeccelPositionMixed...
by laptophead
Wed Jul 18, 2018 3:02 pm
Forum: Velocity and Position Control
Topic: I would like to Sync 2 motors from Arduino commands
Replies: 7
Views: 2044

I would like to Sync 2 motors from Arduino commands

I am using the roboclaw 15A version, great product by the way. In ION Studio, I am able to click the Sync box and move the motors in sync. I dont need that feature all the time. I would like to be able to do it from the Arduino IDE commands; Now I am using: roboclaw130.SpeedAccelDeccelPositionM2(adr...
by laptophead
Tue Oct 17, 2017 2:30 pm
Forum: Velocity and Position Control
Topic: Trying to control 3 motors with packet serial
Replies: 3
Views: 1769

Re: Trying to control 3 motors with packet serial

OK I simplified to two motors and it works. The issues: 1. The motor does not come back to the place (number of pulses ) it came from. Hundreds of pulses apart. I though if it is a PID, it wont stop till the error is 0. Might be slow or overshoot, but it should get there. 2. How do I read the existi...
by laptophead
Mon Oct 16, 2017 5:33 pm
Forum: Velocity and Position Control
Topic: Speed control using pushbutons
Replies: 3
Views: 1910

Re: Speed control using pushbutons

I am also using a keypad to start stop the motors.

Here is a really good article on it.

http://www.circuitbasics.com/how-to-set ... n-arduino/
by laptophead
Mon Oct 16, 2017 5:30 pm
Forum: Velocity and Position Control
Topic: Trying to control 3 motors with packet serial
Replies: 3
Views: 1769

Trying to control 3 motors with packet serial

I was succesfull in moving all 3 a bit, so I'm pretty sure the hardware works. I have done all the PID setup for each of the 2 robotclaws. Now the base motor only goes fwd and not coming back. the rest the same, they behave erratically... I am new at this, please help. I am using a teensy 3.6 here i...