Search found 4 matches

by rymnd
Fri Nov 30, 2018 10:40 am
Forum: Velocity and Position Control
Topic: Trouble running absolute and quadrature encoders on same Roboclaw
Replies: 7
Views: 1737

Re: Trouble running absolute and quadrature encoders on same Roboclaw

Just re-tried it w/ firmware updated to 4.1.27 and using BasicMicro Motion Studio. Same behavior as before. Only additional change I noticed is that when I swap the encoder channels in software, which (somehow) allows me to read the absolute encoder but not the quadrature, the absolute encoder value...
by rymnd
Thu Nov 29, 2018 7:11 pm
Forum: Velocity and Position Control
Topic: Trouble running absolute and quadrature encoders on same Roboclaw
Replies: 7
Views: 1737

Re: Trouble running absolute and quadrature encoders on same Roboclaw

No rush, and no problem. I double-checked and re-did my test cases just in case I did something stupid, but got the same results. Here are my details in full: Hardware connections: - quadrature encoder and gearmotor connected to M1 and Enc1 - potentiometer and linear actuator connected to M2 and Enc...
by rymnd
Wed Nov 28, 2018 2:54 pm
Forum: Velocity and Position Control
Topic: Trouble running absolute and quadrature encoders on same Roboclaw
Replies: 7
Views: 1737

Re: Trouble running absolute and quadrature encoders on same Roboclaw

Yes, the encoder modes are set appropriately for each actuator.
by rymnd
Fri Nov 16, 2018 10:19 pm
Forum: Velocity and Position Control
Topic: Trouble running absolute and quadrature encoders on same Roboclaw
Replies: 7
Views: 1737

Trouble running absolute and quadrature encoders on same Roboclaw

I'm having trouble running 2 motors, one with quadrature encoders, and the other with a potentiometer on the same Roboclaw 2x7A. Motors: - Pololu 37Dx73L gearmotor - Actuonix linear actuator with potentiometer Wiring matches examples given in the documentation: Quadrature encoder is hooked up to ENC...