Search found 4 matches

by gnordin
Fri Apr 19, 2019 3:03 pm
Forum: Velocity and Position Control
Topic: S4 Homing
Replies: 1
Views: 401

S4 Homing

I have a Roboclaw 2x15 and am trying to set up homing on S4 but am having trouble because the voltage on the data pin of S4 is not what I expect (the + and - S4 pins are 5V and GND, as expected). With nothing connected, the voltage on the data pin is 1.86V. This is the same whether I use Motion Stud...
by gnordin
Mon Apr 15, 2019 11:57 pm
Forum: Velocity and Position Control
Topic: Home/Limit switches
Replies: 22
Views: 11149

Re: Home/Limit switches

You have to be in bridged mode. You dont have to actually have bridged the two motor channels but in bridged mode you can only control one motor. It is a check box option in Motion Studio. Once in bridged mode you set S4 and S5 as limit switched. One for home/rev and one for forward. The Roboclaw a...
by gnordin
Fri Apr 12, 2019 12:44 pm
Forum: Velocity and Position Control
Topic: Home/Limit switches
Replies: 22
Views: 11149

Re: Home/Limit switches

I made some changes to the firmware to allow both signal pins to be used as limits for one motor. This will only work when Bridged Channel mode is selected. You dont have to actually wire both motor channels together, but the mode must be selected. When it is the new firmware will let you use both ...
by gnordin
Fri Apr 05, 2019 6:25 pm
Forum: General Discussion
Topic: USB device doesn't appear on Mac
Replies: 13
Views: 8464

Re: USB device doesn't appear on Mac

I have a Roboclaw 2x15A and cannot see it when I plug it into my mac laptop (Summer 2018 laptop, Mac OS 10.13.6). I only have a USB cable attached through a USB-A to USB-C adapter. There are no other connections or power to the Roboclaw. When I execute "ls /dev/tty.*" from the Terminal command line ...