Settings resets to default after firmware update

General discussion of using Roboclaw motor controllers
Post Reply
ugur1yildiz
Posts: 5
Joined: Fri Feb 08, 2019 7:56 am

Settings resets to default after firmware update

Post by ugur1yildiz » Tue Sep 15, 2020 12:50 pm

Hi,

I previously configured some RoboClaw 2x15A Motor Controllers firmware 4.1.33. Now I need to read back the settings by Basicmicro Motion Studio (BMS). When I tried to connect driver it asked to update the firmware to 4.1.34 then I updated. But the drivers settings appeared to be restored to factory defaults and I lost the settings. I have some more drivers with the same settings but again with old firmware 4.1.33.

Now the question;
How can I read the settings of the drivers with old firmware?

If the firmware update can be skipped in BMS or if the version of BMS corresponding to firmware 4.1.33 is available, It can be possible to read the settings on the drivers.

Thanks

User avatar
Basicmicro Support
Posts: 1436
Joined: Thu Feb 26, 2015 9:45 pm

Re: Settings resets to default after firmware update

Post by Basicmicro Support » Mon Sep 21, 2020 8:06 am

You can revert to 4.1.33 using the windows uninstaller. Once that is done you can read the settings, however you will then need to run the full installer for 4.1.34. A reverted version will not look for an update.

ugur1yildiz
Posts: 5
Joined: Fri Feb 08, 2019 7:56 am

Re: Settings resets to default after firmware update

Post by ugur1yildiz » Wed Sep 23, 2020 8:13 am

However I already formatted my computer so I don't have the previous version of BMS. When I uninstall the last version of BMS then I don't have any BMS.

User avatar
Basicmicro Support
Posts: 1436
Joined: Thu Feb 26, 2015 9:45 pm

Re: Settings resets to default after firmware update

Post by Basicmicro Support » Wed Sep 23, 2020 8:18 am

Contact support@basicmicro.com directly. We will, need to dig out an archive which will take some time.

Post Reply