Unable to update Firmware from 4.1.33 to 4.1.34 [SOLVED]

General discussion of using Roboclaw motor controllers
Post Reply
Posts: 11
Joined: Fri Mar 01, 2019 3:13 am

Unable to update Firmware from 4.1.33 to 4.1.34 [SOLVED]

Post by cjr » Thu Apr 22, 2021 6:54 am

Hello everybody.

I have a RoboClaw 2x7A. Freshly installed MotionStudio. This tells me that i have to update from 4.1.33 to 4.1.34, so the RoboClaw is properly detected.
It then tells me to power the RC off, press mode (and hold it, i presume) and power on. Then the LEDs start cycling in the indicated pattern. "Update" simple reopens the same dialog. Over and over again.
So i powered it off and on again, now it's an "unknown USB device". Restarting MotionStudio does not help, the RC is no longer detected.
The LEDs do still cycle the off-green-2xgreen-all sequence, so it looks like it's in bootstrap mode.
Manual tells me to "use IonMotion PC setup utility to clear." But how?

Btw, searching for any interesting subject in the forum (firmware, bootloader, ...) just tells me that the keyword is too common.

Update: The USB Device Driver is installed (see viewtopic.php?f=2&t=715), but this does not help.

Update: Awfully sorry bothering You. The usual Windows Solve-Everthing, a reboot has helped. In fact i needed 2 reboots, but after that the update went smoothly.

Best Regards,


Post Reply