Page 1 of 1

[SOLVED] IonMotion Interface Hangs on Connect

Posted: Tue Oct 27, 2015 7:30 pm
by Ibrahim
Hi there,

I am trying to connect a Roboclaw 2x15A to my computer via USB. The computer is running Windows 10. I installed the drivers and the controller is detected correctly when connected.

After installing and starting the IonMotion software, I click on Device->Connect. The interface hangs. No response to any mouse clicks. The STAT1 LED can be seen blinking very quickly.

I tried also on a Windows 7 laptop with the same result.

If I unplug the USB cable after a while I get the error Get Version: A device attached to the system is not functioning.

Any help?


Edit: Just to add, I've tried different USB ports and different cables, uninstalling and reinstalling drivers and IonMotion, and restarting the computer.

Re: IonMotion Interface Hangs on Connect

Posted: Wed Oct 28, 2015 5:43 pm
by Ibrahim

To anyone who has the same issue; a firmware update solved the issue. Here's how.

1. Connect the Roboclaw to the USB port and supply power to it as usual.
2. Open IonMotion software. You should see your board model (e.g. Roboclaw 2x15A) near the "Update" button.
3. Click the "Update" button and wait (it might take a couple of minutes). The interface will seem to hang.
4. A new dialogue will pop up (in my case it popped up in the background) with instructions on how to put the Roboclaw in bootloader mode or something along those lines. Follow the instructions.
5. When you power on the Roboclaw again it should update the firmware and you can now connect using the Device->Connect menu.

Hope that helps anyone else who ran into the same problem.

Also, just a hint, in the PWM Control area of the software, a realistic acceleration value is 10000. Values less than 1 cause the software to throw an exception. Values less than 4000 make it seem as if it's not responding but in fact it's very slowly ramping up.


Re: SOLVED: IonMotion Interface Hangs on Connect

Posted: Thu Oct 29, 2015 1:02 pm
by Basicmicro Support
Good information, Ibrahim.

I'll add Im adjusting it so it wont take so long for the popup to come up if IonMotion has problems automatically entering bootloader mode.

I just checked and negative numbers do cause an exceptin. 0 didnt though and shouldnt since 0 is a valid accel setting. When 0 is set the roboclaw will use the default max accel rate instead.