Settings appear to change when USB Disconnected

Questions about using encoders with the Roboclaw product line
User avatar
Basicmicro Support
Posts: 1135
Joined: Thu Feb 26, 2015 9:45 pm

Re: Settings appear to change when USB Disconnected

Postby Basicmicro Support » Thu Feb 22, 2018 10:09 am

Yes. I received it just before the end of the day(yesterday).

bearbait
Posts: 13
Joined: Thu Oct 19, 2017 11:41 pm

Re: Settings appear to change when USB Disconnected

Postby bearbait » Mon Feb 26, 2018 4:09 am

Please advise if you have had an opportunity to examine this unit yet.
Kind regards
Bearbait

User avatar
Basicmicro Support
Posts: 1135
Joined: Thu Feb 26, 2015 9:45 pm

Re: Settings appear to change when USB Disconnected

Postby Basicmicro Support » Mon Feb 26, 2018 11:34 am

I have looked at the board. It appears the diode clamp we have on the USB VBus pin on this board is clamping at a bit higher voltage than normal. This is allowing the voltage to go high enough to cause the clamping diode on the input pin of the main processor to start to conduct. This causes the Vcc line to rise slightly above the nominal 3.3v which is also used as the A/D reference. This causes the A/D readings to be slightly different when USB is plugged in versus when USB is not plugged in. The fix is to replace the external clamping diode to prevent the processors clamping diode from conducting.

Unfortunately I dont have any in stock. We currently have a parts order in that should be here sometime next week which has the diode I need.

bearbait
Posts: 13
Joined: Thu Oct 19, 2017 11:41 pm

Re: Settings appear to change when USB Disconnected

Postby bearbait » Tue Feb 27, 2018 1:42 am

Thanks. I will pass this on.
Kind regards
Bearbait

bearbait
Posts: 13
Joined: Thu Oct 19, 2017 11:41 pm

Re: Settings appear to change when USB Disconnected

Postby bearbait » Mon Mar 12, 2018 8:23 am

Any news?
Kind regards
Bearbait

User avatar
Basicmicro Support
Posts: 1135
Joined: Thu Feb 26, 2015 9:45 pm

Re: Settings appear to change when USB Disconnected

Postby Basicmicro Support » Mon Mar 12, 2018 10:54 am

Yes. New part fixed the problem. Got them in Thursday and fixed the board. Was going to ship Friday but got sick Thursday night so I couldn't get to it till today. I will email the tracking to the email you included in your note.

bearbait
Posts: 13
Joined: Thu Oct 19, 2017 11:41 pm

Re: Settings appear to change when USB Disconnected

Postby bearbait » Tue Apr 03, 2018 10:23 am

Thanks, all working now. Apologies for delay in letting you know.
Kind regards
Bearbait

User avatar
Basicmicro Support
Posts: 1135
Joined: Thu Feb 26, 2015 9:45 pm

Re: Settings appear to change when USB Disconnected

Postby Basicmicro Support » Tue Apr 03, 2018 10:37 am

Not a problem. No news is usually good news in my book. :)


Return to “Velocity and Position Control”

Who is online

Users browsing this forum: No registered users and 2 guests

cron