broken the third MCP236 after few turns

General discussion of the MCP motion controller product line
Post Reply
fausto.tromba
Posts: 37
Joined: Wed Jul 31, 2019 7:24 am

broken the third MCP236 after few turns

Post by fausto.tromba » Wed Jan 13, 2021 6:13 am

I have broken the third MCP236 after few turns. I have opened it to check the damage it is another IC that the last time. Probably a current sensor, because the current that I could read by BasicStudio was tot high to be true. please let me know the device.

This is the third in 6 Months. one in October, one in December and one in January.Embarrassing.
Attachments
IMG_20210113_144010 - Copy.jpg
IMG_20210113_144010 - Copy.jpg (254.93 KiB) Viewed 105 times

User avatar
Basicmicro Support
Posts: 1488
Joined: Thu Feb 26, 2015 9:45 pm

Re: broken the third MCP236 after few turns

Post by Basicmicro Support » Tue Jan 19, 2021 9:49 am

The part you have marked is the opamp for the current sense circuit. It is unclear how you could be damaging that part. Unless there is damage else where(eg the HV regulator and/or 5v regulator, which powers the opamp. Does the unit still power up at all?

How are you powering the MCP? What voltage?

The part in question is: AD8602DRMZ

Note, as I stated above I don't see any way you could be damaging that part without having damaged something further up the chain. It see no high voltages(it is using a low side current shunt resistor).

fausto.tromba
Posts: 37
Joined: Wed Jul 31, 2019 7:24 am

Re: broken the third MCP236 after few turns

Post by fausto.tromba » Wed Jan 20, 2021 12:27 am

The set up is always the same since the last 2 years so far... power supply 48V-10A SDR-480-48 in series with a Chopper to pull down the voltage in case it goes higher than 51V. So the supply is less than 60V written in the specification which you guarantee.
The moror are brushed with the inductance of 2mH and Resistance of 2 ohm.

The motors are fine and not broken: by oscilloscope, it is possible to see the ripples.

It is unclear how your MCP236 damaged after few turns.

The MCP can still be powered but it measures wrong currents (100 A that physically does not exist). It is not possible to drive a motor now.

Post Reply