Robot mower build

Post your own projects using Roboclaw motor controllers
User avatar
RoboGangMower
Posts: 10
Joined: Wed May 23, 2018 1:04 pm

Robot mower build

Post by RoboGangMower » Wed May 23, 2018 1:29 pm

I have a mower i have used in the last 2 years, it was never dual motor, zero turn.

But this year it is. i just fried 4 POS motor controllers on ebay so i bought the MCP236 Dual 30A 60 VDC controller.

hopefully it will do what i need it to do.

https://www.youtube.com/watch?v=TDdC8KQ_RjU&t=21s

Here it is on YouTube.
Once i get the controller in, i will update this project. i am a software developer for work, and a hydraulics guy by trade. so hopefully it won't be terribly hard to write the program.

User avatar
Basicmicro Support
Posts: 1201
Joined: Thu Feb 26, 2015 9:45 pm

Re: Robot mower build

Post by Basicmicro Support » Thu May 24, 2018 10:07 am

The dual 30amp may not be enough power for it. Can you tell me the motor specs/model/manufacturer. I can estimate if it should work from that.

We've had customers do mowers in the past but always with a dual 60a system.

PS. Make sure you mount the MCP to a metal chassis with good contact(eg use a thermal interface pad) to get the best performance from it. The small MCP units(23X,26X) use conduction cooling only. I mention it because the China controllers you had were air cooled and mounted to plywood it looks like.

User avatar
RoboGangMower
Posts: 10
Joined: Wed May 23, 2018 1:04 pm

Re: Robot mower build

Post by RoboGangMower » Thu May 24, 2018 1:29 pm

hi. the motors are 1000 watt 48vdc, and yes i am over powering them using 56vdc (57.5 max) lithium batteries (Ego).

which puts me at 1550 watts or something like that.

the dual 60a was just too much money to be honest. the wife would kill me.

the motors run at roughly 8 amps each max during operation, which was up hill. i never registered the max amp draw from a dead start as my cheap display just can't.

https://www.ebay.com/itm/1000W-48-V-DC- ... 5356!US!-1
these are the motors

i have been running them on cheapo china controllers that are rated for 20 amps.

while you are probably correct on needing the 60A versions. i was hoping that controlling ramp up would help me out in this aspect.

the biggest problem i have been having is dealing with limited 60v available components. the batteries i use determine that, and they really do take a beating.

so am i to assume that this controller will not work for me then due to full load amps?

and yes. haha. the ply wood was temporary. i have only mowed 2 x with it. now i need to finalize the system.

i failed to see a peak current per channel so i assumed it would be 60 amps as most things seem to be rated as double the operating amps per channel. is this correct or no?

one more thing.

in my defense, this is my first remote control capable build i have done before, and I don't know things :D

User avatar
RoboGangMower
Posts: 10
Joined: Wed May 23, 2018 1:04 pm

Re: Robot mower build

Post by RoboGangMower » Fri May 25, 2018 11:14 am

Any idea if I am good to go or not with the mcp236?
Because I'm holding it and I will admit I'm pretty excited

User avatar
Basicmicro Support
Posts: 1201
Joined: Thu Feb 26, 2015 9:45 pm

Re: Robot mower build

Post by Basicmicro Support » Fri May 25, 2018 11:26 am

Not sure where they are getting their current rating from. 1000/48 would be just over 20amps but thats the continuous current rating(eg can run 20amps forever and never over heat under 25c ambient). They list 26amps. You could assume that is stall but I doubt that. From my own experience stall current is anywhere from 5 to 15 times the continous current rating of a dc motor. So best case I would guess those motors will pull 100amps at stall. Worse case is much much worse.

How did you measure the amps? 8amps at the battery is not necessarily 8amps at the motors. For example if your battery is sourcing 8 amps and a motor is at 20% duty, then the motor is pulling 40amps(100/20 = 5, 5 * 8 = 40).

Im sorry to say I doubt the MCP236 is going to cut it with those motors. The MCP probably will end up current limiting so much the motors can barely move under load.

P.S. if your china motor controllers were 60v rated thats almost certainly why they died. Most motor controllers that list their voltage rating actualy mean thats the absolue max(eg .1v over that and poof). Most 60v motor controllers will be killed by that setup. That, however shouldn't be a problem with our controllers(we under rate our voltage limit by quite a bit). You may get some overvoltage warnings under decelerations though.

User avatar
RoboGangMower
Posts: 10
Joined: Wed May 23, 2018 1:04 pm

Re: Robot mower build

Post by RoboGangMower » Fri May 25, 2018 11:52 am

Thanks for the reply. I really appreciate your help
I measured 8 amps running from a shunt sensor on the battery line to the motors. Then divided by 2.

I found a calculator that estimates watts based on over voltaging a motor. It said 1550 or something. Those motors are 48v rated and I'm putting 57vdc into them

I was assuming because they were pwm controllers that the amps out would be greater than amps into the motors due to inefficiencies, as I thought pwm would be full voltage in pulses.

Again I'm a super amateur here.

The china controllers (junk I know) were rated for 60v Max. The caps and other components were all 80 or 85vdc but that is all I could see.

So I assume If I try this controller out and it doesn't work, I can't return it. Or can I? I got it from robotshop.com. I didn't find your site before I bought it.

User avatar
RoboGangMower
Posts: 10
Joined: Wed May 23, 2018 1:04 pm

Re: Robot mower build

Post by RoboGangMower » Fri May 25, 2018 11:53 am

So after all my probably wrong information I have supplied :D

What would you recommend?

Thanks again for all of your help. I do appreciate it

User avatar
Basicmicro Support
Posts: 1201
Joined: Thu Feb 26, 2015 9:45 pm

Re: Robot mower build

Post by Basicmicro Support » Tue May 29, 2018 10:05 am

Amps into the Motors from a PWM drive are always equal to or higher than the amps measured at the batter munis minimal losses. Its just the way it works. Current wants to flow so what gives in a PWM is volts. A PWM running 50% duty into a motor will produce 1/2(approximately) the battery voltage but will have twice the battery current.

Watts in equals watts out(minus resistive losses).

My guess is they used 60v max rated mosfets(its what alol of motor controllers use when they "rate" their controllers. We use 100v mosfets on our 60v controllers. This is because the inductive spikes can go much higher than the battery voltage and when we say60v we mean usable 60v.

As long as the board is in working order, if it isnt enough you should be able to return it. Just explain it wasnt large enough for your job and I think they will take it back.

Alternatively you could send it in to us and trade in for a MCP266 for the difference in price.

But over all that make sure you have good cooling(mounted well to a metal chassis. Poor cooling will make even a good controller not operate well.

User avatar
RoboGangMower
Posts: 10
Joined: Wed May 23, 2018 1:04 pm

Re: Robot mower build

Post by RoboGangMower » Tue May 29, 2018 10:19 am

well that seems very convenient.

i shall trade up then.

This is unheard of support. thank you so much.

User avatar
RoboGangMower
Posts: 10
Joined: Wed May 23, 2018 1:04 pm

Re: Robot mower build

Post by RoboGangMower » Sat Jun 16, 2018 11:04 am

https://youtu.be/kFqouZvOQAE

It's working

I love the mcp-260a, it is so responsive!!

Post Reply