Two Roboclaw 2x200A show no status LEDs, do not enumerate on USB bus

General discussion of using Roboclaw motor controllers
Post Reply
Posts: 1
Joined: Fri Mar 08, 2019 5:53 pm

Two Roboclaw 2x200A show no status LEDs, do not enumerate on USB bus

Post by dCentralizedSystems » Fri Mar 08, 2019 6:00 pm

Hi, i recently ordered two 2x200A roboclaw controllers, installed them on our 36V (8KWh battery capacity) robots, and after a few days of successful operation, they both stop enumerating on the USB bus, and have *no* status LEDs illuminated.

We have experience with about 8 different brands of DC motor controllers but here is our setup for reference:

- Roboclaw in dual channel configuration is connected to 36V SLA battery bank
- Marine grade disconnect switch on the positive line
- USB in packet serial mode used for control, from a raspberry PI

The controllers where "verified" by using the Ion Control studio windows app, verified current limit set to 2x200, then installed on our robots (dual channel configuration, one controller per robot).
We drove around both robots for several days, no issues, using USB in packet serial mode.

As of this morning however, neither controller shows any status indicator lights (verified voltage is still 40V across battery terminals to controller) and no longer enumerates on the USB bus. Robots were indoors, unheated space (about 38 deg F)

There are NO linux kernel logs when we plug in the roboclaw controllers anymore, the controllers are completely dead.

Any hints, suggestions? I tried plugging them in to a windows laptop, powering them using a DC power supply at 30V, and they still do not show up on USB, no status LED present.

Again, they worked fine for several days and they were both idle overnight Thursday, and both worked, before we tried using them Friday (March 8th 2019) in the morning.

our order was BM-2102.


User avatar
Basicmicro Support
Posts: 1518
Joined: Thu Feb 26, 2015 9:45 pm

Re: Two Roboclaw 2x200A show no status LEDs, do not enumerate on USB bus

Post by Basicmicro Support » Tue Mar 12, 2019 10:23 am

Just to confirm, these were working ok initially and then stopped?

I will try contacting you directly using the information in the invoice. If you dont hear from me by the end of the day please call 800-535-9161.

If they just stopped working there are couple things that can damage controllers that are non-obvious. For example, if you disconnect power and then start pushing wheeled vehicles around you dcan cause enough regeneration that it will ramp up voltage on the controllers to dangerous levels. To prevent this problem you need to make sure you have a diode to bypass your power contactor which will provide a path back to the battery when the battery is otherwise disconnected.

Alternatively a volce clamp can be added which will disipate the regen energy(even when not powered from the battery if regen raises the voltage too high.

Since no lights are coming up I suspect the high voltage logic switching regulator may have been damaged(also a symptom of regen induced over voltage though there are other possibilities).

I'll go over this and any possible other causes when I call.

Post Reply