Recovering proper operation after firmware update

General discussion of using Roboclaw motor controllers
Post Reply
troubleshooter
Posts: 5
Joined: Thu Jul 18, 2019 3:17 pm

Recovering proper operation after firmware update

Post by troubleshooter » Sat Jul 20, 2019 12:20 pm

Is anyone around on weekends here? (I'm in a bind)
[UPDATE 7-20-19: I think I worked it out!!!}
-you can ignore the following, unless you have the same problem; my solution below-

I am working on a unit someone else built and don't have any info on the Arduino UNO controller/programming.

I was working on a speed flutter issue.
At one point an encoder lead fell off, but the unit continued to respond to speed change commands from the Arduino. (posted separately and got explanation already)
At which point I wanted to see what I could with the Motion Studio app, which I downloaded and installed.
I was told I could see the PID values, and motor parameters.
When I tried to use it, it would not let me see current settings until I updated the firmware.
After I did that, the Arduino lost control of the motors.

Can anyone talk me through the basics, perhaps something not explicitly stated that I did wrong?
It said nothing about disconnecting anything during the update.
Is the serial input a conflict?

It now works if I 'toggle' the input mode to another and back, but quits responding again after power-down.
I can't get it to operate again without the studio connected.

Mr K L


UPDATE 7-20-19:
I guess I solved it.
After the firmware update, even though the Motion app, and the button status readout, both indicated it still was already in mode 7; but, I had to resave it in order for it to function.
I did this by the app.
I think I had already tried that by the buttons (mode flash code, then B3-save), and that did not do anything...
(I tried MANY things, except any writing or altering settings)

I used Basic Motion Studio's 'Device' 'Write Settings', then disconnected; then it would boot up and operate by the Arduino UNO, without the app connected.

Firmware was updated from 4.1.26 to 4.1.33
I wonder if the firmware altered the settings table allocations or syntax.

Mr K L

User avatar
Basicmicro Support
Posts: 1232
Joined: Thu Feb 26, 2015 9:45 pm

Re: Recovering proper operation after firmware update

Post by Basicmicro Support » Mon Jul 22, 2019 10:08 am

The firmware certainly changes the order of the saved settings but from such an old firmware I would have expected it to automatically reset the settings. Sorry about the trouble.

In cases where odd things are happening after a firmware update, I definitely recommend restoring defaults and setting up fresh.

Let me know if you still have any problems.

Post Reply