Reoccuring high current on Motor 2 channel

General discussion of the MCP motion controller product line
Post Reply
ChrisG
Posts: 2
Joined: Thu Feb 06, 2020 12:49 am

Reoccuring high current on Motor 2 channel

Post by ChrisG » Thu Feb 06, 2020 12:59 am

Hi,
we have a problem with some of our Roboclaws. Initially we expected some component damage (power supply, motors, Roboclaw...).
However in the meantime the behavior is very strange.

What we see is, that we get an over current warning on Motor 2. We changed channels, replaced motors and the Roboclaw.
Running Motion Studio, it seems the over current mainly occurs when we run the motor very slow. We also connected a brand new motor, without any load...

Background:
Recently we had to upgrade to Firmware 4.34 from 4.33 as we wanted to include a speed error limit trigger (not done yet).
We run two Roboclaws in serial. However, I also tried them with Motion Studio while being disconnected (still setup to multi-mode).

Questions:
1. Is there anything that could cause an over current behaviour by software?
2. Did anyone observe current warnings with Firmware 4.34?
3. Did anyone had reoccuring current warnings on Motor Channel 2?

User avatar
Basicmicro Support
Posts: 1435
Joined: Thu Feb 26, 2015 9:45 pm

Re: Reoccuring high current on Motor 2 channel

Post by Basicmicro Support » Thu Feb 06, 2020 10:36 am

Adjust the current blanking percentage to a little higher value. It defaults to 5.4% buy may need to be adjusted for different motors. The symptom of a false over current is when you see it tripping at very low duty cycle.

You can change the setting in the General Settings Screen of Motion studio. Most likely changing the value to somewhere between 6 and 8% will fix eliminate the false over current readings.

The blanking window sets how wide the PWM duty must be before valid current readings can be made. When the duty is very low there is too much noise to take valid current readings. How noisy this is is partially a function of the motor being used which is why we have made the setting adjustable.

Post Reply