RoboClaw 2x60A (V6C) Low Logic Battery Error on startup

General discussion of using Roboclaw motor controllers
Post Reply
User avatar
Basicmicro Support
Posts: 1594
Joined: Thu Feb 26, 2015 9:45 pm
Re: RoboClaw 2x60A (V6C) Low Logic Battery Error on startup

Post by Basicmicro Support »

When NOT using hte logic battery input, it is possible under some conditions that the Logic Battery input will float. If it floats higher than 3v it can cause a false LB error. The correct fix for this is to short(and leave shorted) the LB+- pins. There is a diode in circuit with the LB+ pin so no power is being shorted when you do this. It just prevents the pin from floating causing false errors.
Posts: 2
Joined: Tue Nov 03, 2020 8:50 am
Re: RoboClaw 2x60A (V6C) Low Logic Battery Error on startup

Post by seurban »

Hi, I'm having the same issue but shorting the LB + - pins doesn't work for me. Shorting it doesn't fix the low logic battery error (I have to update firmware each time this happens) and having the short doesn't prevent the error.

Are there any other fixes to try? I don't recall having this error initially, but after not using the roboclaw for a bit it now happens consistently. I can prevent this by hooking a 9V battery to the LB in before I switch this on, which works ok for now while I develop my project but isn't a good solution for after I hand this of to someone to use in the field. I can turn off the 9V battery after it has started up without any issue, it just has to be on at startup.

My Setup:
2x60A (34VDC) Roboclaw
Roboclaw Screw Terminal Adapter (where I tried to short the LB IN using the screw terminals and connect the 9V battery)
24V motor battery
Precharge circuit with a 220 ohm resistor (I hover there for a second or two before switching full power on)
Posts: 10
Joined: Sat Jul 10, 2021 7:40 am
Re: RoboClaw 2x60A (V6C) Low Logic Battery Error on startup

Post by stef308 »

I have had the same problem with my 2x60A. I have solved it by the following settings for a LiFePo battery 24V (full charged 29.7V and empty 22.5V):

Max Main Battery 34.0V
Min Main Battery 22.5V
Main Battery Offset 0.0V
Max Logic Battery 34.0V
Min Logic Battery 5.5V
Logic Battery Offset 0.0V

You have to write the settings to the Roboclaw for storing them. After that, I disconnect it with the button on IonMotion and reconnect it for checking, if the new settings are stored. If not, repeat it or try to reset your Roboclaw and make all settings the first time you connect it to the computer. This worked for me. Now after some time of use, it works without such problems, but at the beginning I have had also some difficulties to get the settings uploaded!

Post Reply