Default packet address not changing

General discussion of using Roboclaw motor controllers
Post Reply
raghu_n
Posts: 1
Joined: Sun Mar 01, 2020 7:09 pm

Default packet address not changing

Post by raghu_n » Sun Mar 01, 2020 7:22 pm

Hi,

I bought two Roboclaw 2x45A motor controllers. I was able to connect to the Basic Micro software and run basic tests of my motors. I was also able to connect (each individual Roboclaw) to my Raspberry Pi and communicate and control the the two motors connected in default state. I need to use two 2x45A MCs (4 motors) and need to use in multi-unit mode.
However, when I tried to change the packet address of the motor controller, via the the Basic Micro software, it does not change. I am trying to assign 128 and 129. When I connect to the Roboclaw and read the general settings, the address does show 129. However, the address in the top left box (where it lists the COM ports), the address shows up as 128. When I connect to the RPi, the Roboclaw only responds to the address of 128 (0x80). I have confirmed multiple times with the Basic micro software that the address is set to 129. Basically, both my Roboclaws only respond to the address 128. I am pretty sure I am using the 'write settings' option in the menu and if I read the settings, the address does show up as 129.

FYI, I have tested with another set of 2x7A roboclaws that I have they work perfectly fine with RPi in multi-unit mode.

What do I need to do to fix this?

User avatar
Basicmicro Support
Posts: 1335
Joined: Thu Feb 26, 2015 9:45 pm

Re: Default packet address not changing

Post by Basicmicro Support » Mon Mar 02, 2020 10:15 am

Changes to the packet address will not take effect until the unit is power cycles. So change the settings. Then go to the Device menu and click Write Settings, then disconnect from the unit, power cycle the board and reconnect. The address should now be set to the one you specified.

This is the only setting that will not take effect until the unit is power cycled because it is required for proper communications within Motion studio.

Post Reply