Motor run fast at power On

General discussion of using Roboclaw motor controllers
Post Reply
JavierGranado
Posts: 4
Joined: Tue Jun 09, 2020 8:50 am

Motor run fast at power On

Post by JavierGranado » Tue Jun 09, 2020 9:15 am

I have a problem with the RoboClaw 2x60A Motor Controller. I have wiring it to two brushed motors and a 24 Vdc batery.

I have connected to a Pixhawk like analog control mode and I have select Exponential RC/Analog Options. Everything Works fine but when I power off and power on again, the motors run to a maximun speed and I must to connect the usb Roboclaw to the Pc, run the Ion Studio and for example, deselect and select again the Exponential option and suddenly everything Works fine again, if not, is not posible to control the Roboclaw in manual mode with the Pixhaw (via joystick)…When the Pixhawk and the telemetry and everythng is ready after the power-On, the motors still running at full speed and there is not possibility to control them...Only after the "deselect and select again the Exponential option", the Pixhawk takes the control.

I cheked that the Roboclaw save the parameters when write settings and after the Power On they are correct, so I don`t understant what happend but I need a solution because the system is a autonomus Vehicle and is mandatory that after a Power On the system remains in stop mode.

Can you help me?

User avatar
Basicmicro Support
Posts: 1387
Joined: Thu Feb 26, 2015 9:45 pm

Re: Motor run fast at power On

Post by Basicmicro Support » Wed Jun 10, 2020 8:05 am

Normal analog mode autocalibrates to the input signal on power up. Set MCU option to disable autocalibration then trim to zero speed using the pixhawk settings.

Note I've never used a Pixhawk and I did not know it could output analog signals. Are you sure this is correct. I was under the impression it outputs RC pulses.

JavierGranado
Posts: 4
Joined: Tue Jun 09, 2020 8:50 am

Re: Motor run fast at power On

Post by JavierGranado » Wed Jun 10, 2020 8:27 am

Yes, I think so about RC output but when I select RC control it doesn't work at all, the motors don't move…
Only Works fine with Analog mode selected...

JavierGranado
Posts: 4
Joined: Tue Jun 09, 2020 8:50 am

Re: Motor run fast at power On

Post by JavierGranado » Thu Jun 11, 2020 1:38 am

I solved parcially the problem with your suggesttion:

.."Normal analog mode autocalibrates to the input signal on power up. Set MCU option to disable autocalibration then trim to zero speed using the pixhawk settings…"

Now, the ROboclaw Start a full speed but it stop when the pixhawk is ready to go and take the control...after sereval seconds of th Power On. So it is better that before. I check that the Roboclaw Start at Full speed even without wiring the control signal of the Pixhawk, so the question is if it is posible to setup the Roboclaw to Starts at zero speed by default when Power On

User avatar
Basicmicro Support
Posts: 1387
Joined: Thu Feb 26, 2015 9:45 pm

Re: Motor run fast at power On

Post by Basicmicro Support » Thu Jun 11, 2020 8:08 am

Do not use analog mode when your control input is NOT an analog signal. Analog mode will take ANY voltage imput and interpret it as a motor command. A RC pulse input looks like mostly a low voltage so of course the motor is taking off in reverse at near full speed.

If the PixHawk doesn't output an analog control signal you shouldn't be using analog mode on the Roboclaw.

Unfortunately I can debug Pixhawk problems. You can determine if there is a problem with RC mode on your Roboclaw by hooking up an RC radio receiver and testing that way. In 10 years the only problem I have ever seen with RC mode was the RC signal being too low a voltage. If you have a scope you should check that as well but I've had other customers use PixHawk controllers without problems so it is unlikely.

JavierGranado
Posts: 4
Joined: Tue Jun 09, 2020 8:50 am

Re: Motor run fast at power On

Post by JavierGranado » Fri Jun 12, 2020 1:33 am

ok, I know what you mean, but I don't understand Why the motors doesn't move at all when I select RC input mode control (in Roboclaw panel) and it Works perfect when I select Analog mode Control. In analog mode Control the motors run
perfect forward and reverse when I control them from the joystick plugging into the PC via Mission Planner for telemetry with 4G to the Pixhawk connected to a Raspberry for telemetry transmission...

User avatar
Basicmicro Support
Posts: 1387
Joined: Thu Feb 26, 2015 9:45 pm

Re: Motor run fast at power On

Post by Basicmicro Support » Fri Jun 12, 2020 8:15 am

Obviously its not running perfectly in analog control mode. Your own description says it is taking off.

You need to confirm the PixHawk is doing what you expect or you need to hook up a regular RC receiver to the Roboclaw and confirm RC mode is working on the Roboclaw.

I can only explain this so many times. Analog mode will take ANY SIGNAL and interpret it as a motor movement. That doesnt mean its working correctly.

Post Reply